MENU

shadowsocks-libev在Debian下新编译安装方法

August 15, 2017 • Read: 524 • 各种资源

必要的更新

apt-get update && apt-get upgrade

安装必要组件

可能需要添加jessie-backports

apt-get install --no-install-recommends gettext build-essential autoconf libtool libpcre3-dev asciidoc xmlto libmbedtls-dev libev-dev libudns-dev

编译安装libsodium

git clone https://github.com/jedisct1/libsodium.git
cd libsodium
./autogen.sh
./configure
make
make install

下载shadowsocks-libev源码包并编译

git clone https://github.com/shadowsocks/shadowsocks-libev.git  
cd shadowsocks-libev  
git submodule update --init --recursive  
./autogen.sh
./configure
make  
make install

其他
运行出现下面报错的话,运行下ldconfig就行。

error while loading shared libraries: libsodium.so.18: cannot open shared object